Heavy load on servers causing intermittent downtime
Incident Report for feeder.co
Resolved
We think have found the underlying issue. Everything is loading normally again.
Posted 2 months ago. Jun 11, 2019 - 19:29 CEST
Investigating
We are currently investigating this issue.
Posted 2 months ago. Jun 11, 2019 - 18:09 CEST
This incident affected: feeder.co.